Phone Number Look-Up
Incident Report for TextUs™
Resolved
The network database issue with our phone number look-up provider has now been resolved. If you continue to run into issues, please reach out to us at support@textus.com
Posted 9 months ago. Jan 05, 2018 - 12:12 MST
Investigating
Our phone number look-up provider is experiencing network database issues. As a result, your TextUs mobile phone/landline look-ups are currently coming back incorrectly. Their operations center is working on this and we keep you updated when the problem has been resolved.
Posted 9 months ago. Jan 05, 2018 - 12:08 MST