Possible Outage
Incident Report for TextUs™
Resolved
We have resolved the issue and apologize for the outage. Due to a backlog of requests there may be some residual slowness as systems come back up to speed.
Posted 4 months ago. Dec 22, 2017 - 11:15 MST
Investigating
We are investigating reports of a possible outage and will have further information shortly
Posted 4 months ago. Dec 22, 2017 - 10:57 MST