Inbound calls failing to TextUs Voice
Incident Report for TextUs™
Resolved
We have identified and fixed the source of the routing issue that caused inbound calls to go straight to voicemail. Please contact Support if you have any ongoing issues with TextUs Voice!
Posted 4 months ago. Feb 04, 2019 - 09:10 MST
Identified
We have identified an issue with TextUs Voice that is causing inbound calls to go straight to voicemail. We are working with our third-party Voice provider now to find a resolution, and we will post updates here as they become available.
Posted 4 months ago. Feb 04, 2019 - 08:06 MST
This incident affected: TextUs Voice.