Multiple notifications
Incident Report for TextUs™
Resolved
We believe this issue to now be resolved but will continue to monitor throughout the day.
Posted 29 days ago. Apr 27, 2018 - 11:20 MDT
Investigating
We are investigating reports from some customers of receiving multiple notifications for the same SMS on desktop and mobile. We suspect this is due to a third party system we use for notifications
Posted 29 days ago. Apr 27, 2018 - 10:07 MDT