Chrome Extension Group's failing to load
Incident Report for TextUs™
Resolved
The issue is now resolved
Posted 9 months ago. Jan 22, 2018 - 13:28 MST
Investigating
We're currently investigating reports of the Chrome Extension failing to create Groups. Other functionality does not seem to be affected.
Posted 9 months ago. Jan 22, 2018 - 08:33 MST