Duplicate Inbound messages
Incident Report for TextUs™
Resolved
We have resolved the duplicate message issue and apologize for inconvenience caused.
Posted 9 months ago. Jul 11, 2018 - 11:34 MDT
Identified
We are currently investigating multiple inbound messages of the same SMS into TextUs at this time we do no have an ETA on resolution.

The issue does not appear to affect outbound messages.
Posted 9 months ago. Jul 11, 2018 - 11:22 MDT
This incident affected: TextUs Web App.