TextUs Chrome Extension not compatible with latest Google Chrome Update (Version 73)
Incident Report for TextUs™
Resolved
We have released a fix for the issue that was causing the TextUs Chrome Extension to fail in the newest version of Google Chrome (Version 73.0).

To make sure your Chrome Extension is up to date and working with the new version, please follow the steps below:

1. To automatically push the update to the Chrome Extension, go to Google Chrome Menu (three dots in upper right corner) > Help > About Google Chrome
2. Completely restart Chrome

Please reach out to Support if you continue experiencing issues with the Chrome Extension, or need assistance on the above steps. Thank you for your patience while we worked to resolve this!
Posted Mar 13, 2019 - 13:07 MDT
Identified
The TextUs Chrome Extension is displaying a blank screen for all users who are using the most recent update of Google Chrome (73.0).

The TextUs Web App (app.textus.com) remains unaffected, and all messages should be sending and receiving successfully.

We have identified the issue and are working on a fix. If having functionality of the Chrome Extension is of utmost importance for your users, the only solution at the moment would be to downgrade to the previous Chrome version. (https://support.google.com/chrome/a/answer/7125792?hl=en)

We are working on a fix with the highest priority and we will continue to post updates here as we have them!
Posted Mar 13, 2019 - 09:24 MDT
This incident affected: TextUs Chrome Extension.