MMS Delivery Delays
Incident Report for TextUs™
Resolved
This incident has been resolved.
Posted 10 months ago. Aug 09, 2018 - 08:13 MDT
Investigating
Some users may experience delivery delays for MMS (Multimedia Messaging Service) messages. One of our SMS Providers has had an issue resulting in mobile-terminated MMS delivery delays in the US, and they are working with their partner to resolve the issue. We will provide updates as we receive them.
Posted 10 months ago. Aug 06, 2018 - 07:48 MDT
This incident affected: Twilio SMS.