Toll Free Number Messaging
Incident Report for TextUs™
Resolved
The issue with our toll free provider has been resolved. Please reach out to support@textus.com if you are still experiencing any issues.
Posted 5 months ago. Dec 05, 2017 - 09:14 MST
Investigating
Our toll free provider is having technical issues with delivery to and from toll free numbers. This may directly impact any TextUs Accounts that are using a toll free number.
Posted 5 months ago. Dec 05, 2017 - 08:28 MST