Redeployment
Incident Report for TextUs™
Resolved
TextUs is now fully operating once again and we apologize for any inconvenience caused
Posted 16 days ago. May 10, 2018 - 14:44 MDT
Update
Our engineering team is deploying a fix currently.

We do not have an ETA at this time but will keep you posted here with further information
Posted 16 days ago. May 10, 2018 - 14:41 MDT
Monitoring
TextUs is currently rolling back a change that caused some temporary issues in performance. The app will be unavailable whilst this completes.
Posted 16 days ago. May 10, 2018 - 14:14 MDT